Identity Manager - Error message is displayed every 30 seconds in the Identity Manager log file
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Identity Manager - Error message is displayed every 30 seconds in the Identity Manager log file

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Article ID: 132562

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Updated On:

Products

CA Identity Manager CA Identity Governance CA Identity Portal

Issue/Introduction

The error message listed below is generate every 30 seconds in the Identity Manager log file:

ERROR [ims.tmt.schedule] (iam_imDefaultQuartzScheduler_Worker-9) com.netegrity.webapp.page.special.ScheduleResubmitExecutor: java.lang.NullPointerException 
at com.netegrity.webapp.page.special.ScheduleResubmitExecutor.execute(ScheduleResubmitExecutor.java:58) [user_console.jar:] 
at org.quartz.core.JobRunShell.run(JobRunShell.java:199) [quartz-all-1.7.3.jar:] 
at org.quartz.simpl.SimpleThreadPool$WorkerThread.run(SimpleThreadPool.java:546) [quartz-all-1.7.3.jar:] 

Environment

Identity Manager 12.6.x
Identity Manager 14.x
Virtual Appliance and non-Virtual Appliance versions

Cause

About this error, check if there is some Bulk Tasks scheduled to run OR some scheduled Snapshot. 
If so, check the possibility to delete the tasks which are not being in use. 
If there is no Bulk Task scheduled or Snapshot, check in the DB, if the "QRTZ_JOB_DETAILS" table is empty, no rows. 
The code will check the ENV_ID and fetch this table. 
 

Resolution

If you have rows and no schedule tasks, do the following procedure:

1. Backup the data of the tables below
   - QRTZ_TRIGGERS 
   - QRTZ_CRON_TRIGGERS 
   - QRTZ_JOB_DETAILS 
2. Stop Identity Manager service
3. Delete the rows from the tables above
4. Restart Identity Manager service


 

Additional Information

In case this is not the error or the problem still persist, open a case with Broadcom Support to better analyze the log file.