Unable to launch Javelin Open Browser Function for FireFox
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Unable to launch Javelin Open Browser Function for FireFox

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Article ID: 132503

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Updated On:

Products

CA Test Data Manager (Data Finder / Grid Tools)

Issue/Introduction

When attempting to execute the “Open Browser” component in Javelin to launch a Selenium recording and open the Firefox browser, we are seeing the following error:

Error executing Open Firefox: Failed to start up socket within 45000 milliseconds. Attempted to connect to the following addresses: 127.0.0.1:7055.
 



What do I need to do to get Javelin 2.0.500.1 to work with Firefox 66.0.2?
The TDM 4.7 documentation states that TDM 4.7 Portal supports Mozilla Firefox 54 or higher.
 

Environment

TDM
Test data Manager
Javelin

Cause

Javelin is a stand-alone component that can be used with TDM or run independently.
It has its own installation requirements, which are not tied to the TDM Portal installation requirements.

The latest patches can be found on the below link
Test-Data-Manager-TDM-Patches
https://support.broadcom.com/web/ecx/support-content-notification/-/external/content/release-announcements/Test-Data-Manager-TDM-Patches/16649

Please review the Requirements below:
System Requirements (broadcom.com)

Unfortunately, we do not document the supported browsers.
 

 

Resolution

However, this is a documented known error.
The troubleshooting steps can be found in the “Javelin Troubleshooting” section of the Javelin documentation, which can be found at:
Javelin Troubleshooting (broadcom.com)

To resolve the socket timeout issue, when attempting to open the Firefox driver, you need to:

  1. Open a Web browser and navigate to http://selenium-release.storage.googleapis.com/index.html
  2. Locate the latest version folder which contains the selenium-dotnet-<version>.zip file.
    At the time this document was create the latest release was found in the 3.5 folder: selenium-dotnet-3.5.2.zip

  1. Download the selenium-dotnet-<version>.zip file and extract the WebDriver.dll and WebDriver.Support.dll files from the zip file.
  2. On the Javelin Server, open a File Explorer and navigate to the Javelin Install directory. By default this would be C:\Program Files (x86)\Grid-Tools\Javelin\ directory.
  3. Rename the existing WebDriver.dll and WebDriver.Support.dll files to WebDriver.dll.original and WebDriver.Support.dll.original
  4. Paste in the new versions of the WebDriver.dll and WebDriver.Support.dll files extracted from the selenium zip file.



When testing the Javelin flow, you may see a new error displayed:
“Execution complete with error: The geckodriver.exe file does not exist in the current directory or in a directory on the PATH environment variable.
The driver can be downloaded at https://github.com/mozilla/geckodriver/releases.”


If this is the case, go to https://github.com/mozilla/geckodriver/releases and download the gekodriver file.
If you are using the 64-bit version of Firefox, I would use the 64-bit version of the gekodriver.


Unzip the downloaded gekodriver-<release>-win32/64.zip and place the geckdriver.exe file in the Javelin install directory.
By default this is the C:\Program Files (x86)\Grid-Tools\Javelin\ directory.
 
Your Javelin flow should now open the Firefox driver when running the “Open Browser” component in Javelin.

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