TDM: Unable to connect to DB2 due to security mechanism error

book

Article ID: 132494

calendar_today

Updated On:

Products

CA Test Data Manager (Data Finder / Grid Tools)

Issue/Introduction

Description:
*************
gives errors to connect to the connection profile used. Error:
*******
Failed to connect: TDMDatabaseException: getDBConnection: Unable to connect to database jdbcdb2://ddb2-gwy01.bmogr.net:3776/dbg4:securitymechanism=7,encryptionalgorithm=2;;;user=mbhat06: Failed to obtain JDBC Connection; nested exception is com.ibm.db2.jcc.am.SqlinvalidAuthorizationSpecException:[cc][t4][201][11237][4.24.92] Connection authorization failure occurred. Reason: Security mechanism not supported. Errorcode=4214, SQLSTATE=28000

Environment:
****************
TDM 4.8 Portal 4.8.0.x

Cause

Used incorrect Default Variable
Had the wrong default variable - corrected and was able to proceed

Environment

TDM 4.8 Portal 4.8.+

Resolution

Open GTDatamaker
Open the projects
Open the variables


Double click the highlighted link to open
Edit Project Level Variable.

 




Edit from CADS to CADS-Target

Additional Information

Video URL on how to open a Support Case - https://communities.ca.com/videos/5898-demo-how-to-open-a-support-case

You can download the latest version of ARD by following the directions in this document: https://support.ca.com/us/knowledge-base-articles.TEC1903942.html.   

To contact support, go to https://www.ca.com/us/services-support/ca-support/contact-support.html. 
 

Attachments

1559050889075000132494_sktwi15okjw4363bk.png get_app
1559050887344000132494_sktwi15okjw4363bj.png get_app
1559050885517000132494_sktwi15okjw4363bi.png get_app