UIM and Serviceaide (CSM) integration not working through the nsdgtw probe
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UIM and Serviceaide (CSM) integration not working through the nsdgtw probe

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Article ID: 132415

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

The nsdgtw probe is not creating incidents in ServiceAide.  This integration was working as expected earlier but is no longer working.  No incidents are created in ServiceAide when UIM alarms are assigned to a specific user.

Environment

UIM 8.51 (but valid in any release)
nsdgtw:  1.34 (or any supported version)

Cause

The user assigned to the UIM alarm did not matched the configured Assigned User in the nsdgtw probe.  The probe ignores any alarm_assign message if the user in the assigned_to field does not match the user specified in the Assigned User field of the nsdgtw probe's Configure GUI.

Resolution

The Assigned User in the nsdgtw probe defines the username of the CA UIM user that UIM alarms are assigned to that should initiate a request to generate a new incident in ServiceAide when the UIM alarm is assigned to this user.  New incidents will not be created of the user assigned in the UIM alarm is different from the user configured in the nsdgtw probe.