QoS metrics from the cdm probe stop being collected after Enhanced template profiles are deployed
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QoS metrics from the cdm probe stop being collected after Enhanced template profiles are deployed

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Article ID: 132412

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

The CDM probe stopped collecting the QoS metrics. A review of the cdm.cfg file on the robot shows that none of the QoS metrics have been enabled so the probe does not publish any metrics. A review of the plugin_metric.cfg file on the robot shows that the CDM enhanced templates were successfully deployed to the robot and QoS publication to the bus  is enabled for the desired cdm QoS metrics (publish_qos = true). The status column for all enhanced CDM templates for the robot in the SSRV2Profile table is set to ok.

Environment

UIM Server:  9.02
cdm probe:  any version that supports enhanced templates (6.33 and higher)

Cause

One way that this condition can occur is if the cdm <version>-MC probe is deleted from the robot, then manually redeployed after the Enhanced templates were successfully deployed to the robot.

Resolution

Use the fix-profile-diffs MCS CLI client utility to force the redeployment of the enhanced CDM probe monitoring profiles to the problematic robot.

Get the cs_id of the problematic robot from the CM_COMPUTER_SYSTEM table:

SELECT cs_id, name from CM_COMPUTER_SYSTEM where name like '%<problematic robot name>%';

Execute the following set of commands depending on the type of Operating System the primary hub is installed on:

For Linux/UNIX:
cd <installPath>/nimsoft/probes/service/mon_config_service/tools
../../../../jre/jre8u102/bin/java -jar mcs-cli.jar fix-profile-diffs -device <cs_id> -action overwrite -username <user> -password <password> -force

For Windows:
cd <installPath>\Nimsoft\probes\service\mon_config_service\tools
..\..\..\..\jre\jre8u102\bin\java.exe -jar mcs-cli.jar fix-profile-diffs -device <cs_id> -action overwrite -username <user> -password <password> -force

where:
<cs_id> = the cs_id of the lxcaapm10cd01 robot
<user> = a UIM user with administrator access
<password> = the password for the specified <user>

This will force the mon_config_service probe to reconcile all of the profiles deployed to the robot with the specified cs_id and the CDM probe QoS metrics should start to be collected after this.

Additional Information

Alternate Resolution:

In some cases the above resolution may not work.  The following steps should resolve the issue when all else fails:

1. Navigate to the "monitoring" tab in UMP for this machine

2. select the 'cpu monitor (enhanced)' profile and scroll down to the bottom

3. make note of the MCS Profile ID 

4. Open an RDP or SSH session to the machine.

  Navigate to (Nimroot)/nimsoft/plugins/plugin_metric
  rename or delete plugin_metric.cfg in this location.

5. Navigate to the machine in IM and select the 'controller' probe -- right-click and choose "update.." then check the box for "replace existing probe" and click OK, or deploy robot_update from the archive to the robot using your preferred method.  (This will replace the plugin_metric.cfg file with the default.)

6. Run the following SQL query, substituting the Profile ID from step 3 where indicated by XXXXX:

update ssrv2profile set status = 'modified', retries = 0 where profileid = 'XXXXX';

7. Deactivate and activate the mon_config_service probe

This should immediately correct the issue.