After upgrading Spectrum to 10.3.2 no more CAPM threshold alarms are being displayed in Oneclick console
search cancel

After upgrading Spectrum to 10.3.2 no more CAPM threshold alarms are being displayed in Oneclick console

book

Article ID: 132373

calendar_today

Updated On:

Products

CA Spectrum

Issue/Introduction

After upgrading Spectrum to 10.3.2, the threshold alarms of CA PM integration are no more able to be retrieved. As a consequence, new threshold alarms are no more displayed at Oneclick console.

In this case, Spectrum is configured to use HTTP (and not HTTPS) to connect on CA PM.

Environment

Spectrum 10.3.2
CA Performance Management 3.7

Cause

During the upgrade process, some old .jar files, related to same component but from different versions,  were not removed from the $SPECROOT\tomcat\lib directory, in the oneclick server. In the example below, the Spectrum upgrade was done in May 8:

-rw-r----- 1 causer causer 2805152 May 8 00:08 ecj-4.9.jar
-rwxr-x--- 1 causer causer 2298872 May 18 2017 ecj-4.4.jar 

-rwxr-x--- 1 causer causer 1047863 May 8 00:08 jaxb-impl-2.2.11.jar
-rw-r----- 1 causer causer 854901 May 18 2017 jaxb-impl-2.1.7.jar

As we can see, the "ecj-4.4.jar" is related to the same component (ecj), but older than "ecj-4.9.jar".

The same applies to "jaxb-impl-2.1.7.jar" and "jaxb-impl-2.2.11.jar" files. 

Resolution

1- Stop Tomcat service at Oneclick Server;

2- Move the older .jar files from the $SPECROOT\tomcat\lib to another folder out of Spectrum directory structure (i.e: /tmp/backup);

OBS: Considering the example provided above, at "Cause" section, you should move the "ecj-4.4.jar" and "jaxb-impl-2.1.7.jar" files.

3- Start Tomcat service at Oneclick server;

4- At CA PM side, stop/start the Event Manager;