Cannot enable/disable polling on interfaces in CA Performance Center (CAPC)

book

Article ID: 132356

calendar_today

Updated On:

Products

CA Infrastructure Management CA Infrastructure Management CA Performance Management - Usage and Administration

Issue/Introduction

Cannot enable/disable polling on interfaces in CA Performance Center

Cause

Symptom: When an interface is synchronized by multiple data sources, including Data Aggregator, and user chooses to disable polling, the dialog says it can't be disabled.  This is because the code is only checking the first data source it is coming from to see if it's the Data Aggregator. 
Resolution: Updated the check, on whether we can disable polling for an interface, to check all data sources the interface comes from, to see if the Data Aggregator is one of them.

(3.6.6_Mar_Update, DE405284, 01270585) 

Environment

CA Performance Management 3.6.5 or earlier

Resolution

This is fixed in CA Performance management 3.6.6 and above,

As a workaround, rest can be used to update the polling status:

1) Find the interface id on the  Data Aggregator Device Admin  page by clicking on the Polled Metric Families tab, selecting interface and exposing the id column
    by mousing over the header column (for example where it says Name) a gear will appear, click the gear and select Columns and check "ID". 

This will cause the ID column to appear so you can get the ID of the interface. 

2) Send a PUT as application/xml to the URL 

http://<da>:8581/rest/pollable/<ID FROM STEP 1> 

With the body: 

<Pollable version="1.1.1"> 
<IsPollEnabled>true</IsPollEnabled> 
</Pollable> 

This will enable polling on that interface. 

Note that you can also disable polling on an interface by using false instead of true.