When attempting to use the attmnt REST method it shows a HTTP 500 error
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When attempting to use the attmnt REST method it shows a HTTP 500 error

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Article ID: 132350

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Updated On:

Products

SUPPORT AUTOMATION- SERVER CA Service Desk Manager - Unified Self Service CA Service Desk Manager CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager

Issue/Introduction

When attempting to use the attmnt REST method it shows a HTTP 500 error, the JREST log shows the error bellow:

ERROR FileUploadUtils ? Exception error on file download operation for attmnt id(XXXXXX). com.ca.sdm.bop.BPMessagingException: java.lang.RuntimeException: Repository Daemon replied with error code: 8

Environment

Service Desk 14.1 or higher

Cause

The file being retrieved did not exist, this was found only if the log level for the rep_daemon process is increased to trace as it can be seen bellow as part of the result of the stdlog file:

rep_daemon 31176 TRACE FileMng.c 500 IsPathExist() - Unable to find path ../PROGRA~2/CA/SERVIC~1/site/attachments/default/servicedesk/files/rep_folder_00001/Name.pdf.gz (No such file or directory (2))

Resolution

In order to verify if the method works properly, test with a recent uploaded file in a ticket, this will guarantee that the file exists in the repository.