Can't edit users after PM 3.7 upgrade
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Can't edit users after PM 3.7 upgrade

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Article ID: 132310

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Updated On:

Products

CA Infrastructure Management CA Performance Management - Usage and Administration

Issue/Introduction

After editing a user role I cannot save, get an error "user admin failed" "the password could not be saved"

Environment

NetOps Performance Management 3.7

LDAP is in use on SsoConfig
 

Cause

In 3.7, we introduced a requirement for complex passwords.

Resolution

This error popup is wrong, changes are actually savedĀ 

We have opened an internal defect and this will be fixed in a future build.

Additional Information

https://techdocs.broadcom.com/us/en/ca-enterprise-software/it-operations-management/performance-management/3-7/release-notes/new-features-and-enhancements.html
 

Authentication Requirements

By default, user passwords must now meet the following heightened requirements:

  • Different from the username
  • Minimum length of eight characters
  • Maximum length of 30 characters
  • Contain at least 3 of the following types of characters:
    • Special characters
    • Uppercase letters (A-Z)
    • Lowercase letters (a-z)
    • Numbers (0-9)

For more information, see Customize Your User Settings.

By default, non-LDAP passwords expire after 105 days. When passwords expire, access to REST and the OpenAPI is blocked. The next time users log in, they must change their passwords. 

You can now enable a setting that disables users after multiple failed login attempts within a timeframe. By default, 6 failed login attempts within 3 minutes disable the user. In addition to disabling the user, you can also block the IP address of the user for a specified amount of time. This functionality is not an intrusion detection system. For more information, see Manage Authentication Requirements.