Rally - On-premises: Error "Service licensing failed"

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Article ID: 132300

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Updated On:

Products

CA Agile Central On Premise (Rally)

Issue/Introduction

After uploading the license file while provisioning a new 2.0 based appliance, the following error is shown:

1 error occurred: * Service licensing failed with error: task: non-zero exit (1)


Checking the "Cluster" screen from the dashboard may show the licensing service in a down state:


Cause

There are a few causes for this error

  • Timing issue
  • Missing license expiration
  • Invalid subscription ID
  • Database communication problem

Environment

Release: RLOPPL99000-2.0-Rally-On Premise-Perpetual
Component:

Resolution

Reboot

Sometimes during an initial deploy there can be a timing issue between the database and licensing containers starting up. A reboot should be attempted initially to resolve this.


Check License Expiration

This issue has been observed when there is no expiration date included with the license file.

To verify the license file:

  1. Click the gear (⚙) icon in the toolbar.
  2. Click View License.

A license with a valid expiration date will show an Expiration Date line as follows:


If your license screen is missing that line, a new license will need to be issued with a valid expiration date.


Check Subscription ID

In most on-premises environments the subscription ID will be 100.  The only reason it would be different is if that environment was migrated from SAAS to on-premises and then the subscription ID would be the value that it was when the subscription was in the cloud.


Check Database Communications

This may be an issue with communication with the database and it is recommended to visit the Database Troubleshooting Guide.

Additional Information

If the expiration date is invalid, the licensing log will show the following error:

2019-05-16T09:33:44.062917226Z CRITICAL >> [05/16/2019 09:33:44 AM] (license_synchronizer.py:23) - The following critical exception has occured, we are exiting the license synchronizer 'expiration_time'

2019-05-16T09:33:44.062961814Z Traceback (most recent call last):

2019-05-16T09:33:44.062973075Z File "license_synchronizer.py", line 24, in <module>

2019-05-16T09:33:44.062982682Z raise exception

2019-05-16T09:33:44.062991465Z File "license_synchronizer.py", line 19, in <module>

2019-05-16T09:33:44.063000783Z license = ReplicatedLicenseAPI.get_license()

2019-05-16T09:33:44.063009623Z File "/_build/service/license_information_service.py", line 34, in get_license

2019-05-16T09:33:44.063018801Z license = generate_license(response.json())

2019-05-16T09:33:44.063037906Z File "/_build/service/license_information_service.py", line 51, in generate_license

2019-05-16T09:33:44.063047899Z license_fields['expiration_time'])

2019-05-16T09:33:44.063056694Z KeyError: 'expiration_time'


If the subscription ID is incorrect, the licensing log will show the following error:

2019-05-30T14:50:39.724521022Z ORA-02291: integrity constraint (RALLYAPP.FK_TAG_SUB_ID) violated - parent key not found

2019-05-30T14:50:39.724763271Z Traceback (most recent call last):

2019-05-30T14:50:39.724780574Z File "license_synchronizer.py", line 24, in <module>

2019-05-30T14:50:39.724804400Z raise exception

2019-05-30T14:50:39.724815362Z File "license_synchronizer.py", line 21, in <module>

2019-05-30T14:50:39.724824664Z license_installer.install()

2019-05-30T14:50:39.724833276Z File "/_build/service/license_installer.py", line 148, in install

2019-05-30T14:50:39.724842317Z self.__finalize_transactions()

2019-05-30T14:50:39.724851028Z File "/_build/service/license_installer.py", line 139, in __finalize_transactions

2019-05-30T14:50:39.724860130Z self.connection.commit()

2019-05-30T14:50:39.724868717Z cx_Oracle.DatabaseError: ORA-02091: transaction rolled back

2019-05-30T14:50:39.724877640Z ORA-02291: integrity constraint (RALLYAPP.FK_TAG_SUB_ID) violated - parent key not found

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