Unable to see data for a custom metric family in OpenAPI

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Article ID: 132294

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Updated On:

Products

CA Infrastructure Management CA Infrastructure Management CA Performance Management - Usage and Administration

Issue/Introduction

After installing a custom metric family ( ex: Ligowave ) the metric shows "no data available in table"  We verified this by adding a query expression in the odata api:

 

Cause

Disconnect between DA and OpenAPI

Environment

CAPM 3.x

Resolution

To resolve do the following:

1. Confirm data is in the tables for vertica.  Connect to vsql and run the following queries
  • select TO_TIMESTAMP(min(tstamp)), TO_TIMESTAMP(max(tstamp)) from ligowave_rate;
  • select TO_TIMESTAMP(min(tstamp)), TO_TIMESTAMP(max(tstamp)) from ligowave_eqd;
  • select TO_TIMESTAMP(min(tstamp)), TO_TIMESTAMP(max(tstamp)) from ligowave_ltd;

2. Assuming current data is returned do the following:

  • http://<da>:8581/system/console/bundles (username and password is karaf / karaf)
  • Search the page for "odata".  There are 4 bundles with an odata prefix.  Stop / Start each bundle using the buttons at the right

Retest the query expression as noted above and it should work

Attachments

1559051302127000132294_sktwi15okjw4363h2.png get_app