Error "address already in use" starting the Administrative User Interface (AdminUI) for CA Siteminder
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Article ID: 132274
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Updated On:
Products
CA Single Sign On Secure Proxy Server (SiteMinder)
CA Single Sign On SOA Security Manager (SiteMinder)
CA Single Sign-On
Issue/Introduction
When starting the AdminUI, this one cannot start properly and reports error :
Error: Protocol handler initialization failed, java.net.mindexception address already in use
This document presents different options for the error and proposes several possible solutions
Cause
At first glance, this error may come from one of the following root causes :
- Another process than the AdminUI is running and uses one of the ports needed by the AdminUI
- There is another instance of the AdminUI running and using already all the AdminUI ports
There is a permissions issue on the OS side
Resolution
- Identify the processes that use the following ports :
5455
8080
8443
5445
Run the following command as root :
# for i in 5455 8080 8443 5445; do ss -tanp | grep $i; done;
You should get something like :
LISTEN 0 128 *:5455 *:* users:(("java",pid=1615,fd=363))
LISTEN 0 50 *:8080 *:* users:(("java",pid=1615,fd=309))
LISTEN 0 50 *:8443 *:* users:(("java",pid=1615,fd=396))
LISTEN 0 128 *:5445 *:* users:(("java",pid=1615,fd=373))
In this sample, the PID 1615 is using these ports.
- Identify what binary process 1615 corresponds to and stop it or remove it from the system memory using the kill program.
Once the PID doesn't show up in memory, run again command :
# for i in 5455 8080 8443 5445; do ss -tanp | grep $i; done;
This time, it should return nothing
- Then start the AdminUI and confirm us this solves the issue
- Ensure there's no permission problem for the AdminUI process and user on the OS
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