Upgrade fails with PLS-00103: Encountered the symbol "" on upgrading Data Warehouse

book

Article ID: 132171

calendar_today

Updated On:

Products

Clarity PPM SaaS Clarity PPM On Premise

Issue/Introduction

During upgrade, error message when upgrading Data Warehouse:
 
 
4/30/19 2:53 PM (ExecTask) DBDriver for datamart_20150912_1039
4/30/19 2:53 PM (ExecTask) Resume installation of DBDriver ...
4/30/19 2:53 PM (ExecTask)
4/30/19 2:53 PM (ExecTask) Note: Foreign Keys have been disabled
4/30/19 2:53 PM (ExecTask) com.ca.clarity.jdbc.oraclebase.ddc: [CA Clarity][Oracle JDBC Driver][Oracle]ORA-06550: line 5, column 73:
4/30/19 2:53 PM (ExecTask) PLS-00103: Encountered the symbol "" when expecting one of the following:
4/30/19 2:53 PM (ExecTask)
4/30/19 2:53 PM (ExecTask) * & = - + ; < / > at in is mod remainder not rem return
4/30/19 2:53 PM (ExecTask) returning <an exponent (**)> <> or != or ~= >= <= <> and or
4/30/19 2:53 PM (ExecTask) like like2 like4 likec between into using || bulk member
4/30/19 2:53 PM (ExecTask) submultiset
4/30/19 2:53 PM (ExecTask) The symbol "*" was substituted for "" to continue.
 
This is indication of issue with mismatch in table definitions.
 

Environment

Release: CODCVU9900-15.5.1-PPM SAAS-View Only Userpack for-Canadian Government Entities
Component:

Resolution

Workaround 1:
Rebuild Data Warehouse from blank schema if possible
Link to Clarity with DB LINK
Run the job successfully
Restart the upgrade
 
Workaround 2:
If this does not work, and your upgrade fails on stage before 15.4, you can try upgrading to 15.3 or lower without DWH set up.
 
To do this:
1. Connect to System Options
2. Remove the Entity for Data Warehouse
3. Save
4. Now run the upgrade again.
5. Once on target version, connect to $clarity\database\backups and restore a fresh DWH backup on this upgraded version
 
Note: Keep in mind that Data Warehouse upgrade can only be skipped to upgrade to versions lower than 15.4