ALERT: Some images may not load properly within the Knowledge Base Article. If you see a broken image, please right-click and select 'Open image in a new tab'. We apologize for this inconvenience.

Rally - On-premises: Loading Please Wait message

book

Article ID: 132149

calendar_today

Updated On:

Products

CA Agile Central On Premise (Rally)

Issue/Introduction

There can be occasions where after a new installation or in some situations after restarting the services virtual machine (VM) that the login screen does not come up correctly and a "Loading Please Wait..." screen is shown instead of the login form.

In some cases, a "504 Gateway Time-out" error may be displayed instead.

Cause

While the application is in the process of coming up and establishing communication with the database, we show the "Loading Please Wait" message to indicate that the application is not yet ready to process login requests.

There are typically three reasons why this page is seen for an extended period of time

  • Cached page
  • Schema migration
  • Database communication issue

 

Resolution

Cached Page

In some cases, if users have encountered this page while the application was still loading, it may become cached in the browser.  When this happens, some users will see the Loading Please Wait screen, while others will be presented with a login page.  If this happens, please clear the cache on the browser.

 

Schema Migration

This can occur after the first startup when migrating a 2018.1 backup to the 2.x platform as there is a data migration that occurs in order to update the database schema.  Depending on the size of the database this can take several additional minutes.  The solution is to continue to wait.  Note that the page may also be cached as indicated above, so you should also try clearing your cache if this screen has been showing for an excessive amount of time.

 

Database Communication Issue

Visit the Database Troubleshooting Guide to troubleshoot this

Additional Information

keywords: agile central caac