UMP dap and wasp probe not accepting port

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Article ID: 132076

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Updated On:

Products

DX Infrastructure Management NIMSOFT PROBES

Issue/Introduction

dap and wasp probe for prod ump is not accepting port.

Cause

- various issues (see resolution)

Environment

- UIM / UMP upgrade from 8.4.7 to 9.0.2

Resolution

Upgrade of 8.47 to 9.0.2 was halted due to issues with UMP portion of install 

dap and dashoard_engine probes leftover from attempted UMP robot upgrade were red. Deactivated and deleted those probes because they are deprecated and no longer used. Only wasp probe is required for UMP now in newer versions. 

https://docops.ca.com/ca-unified-infrastructure-management-probes/ga/en/alphabetical-probe-articles/dashboard_engine-ump-dashboard-service-no-longer-supported 

https://docops.ca.com/ca-unified-infrastructure-management-probes/ga/en/alphabetical-probe-articles/dap-data-access-no-longer-supported 

https://communities.ca.com/thread/241770948-which-probes-have-replaced-dap-dashboardengine 

Changed location of certificate.pem file to directory with no spaces on UIM and UMP robots and adjusted the cryptkey = <file_location\certificate.pem> in the robot.cfg. 

Since wasp probe on the UMP robot never installed correctly we had to do the following: 

- Add data_engine location (NimBUS data_engine address) to the wasp.cfg <setup> section. 

- Emptied data_engine connection string and restarted but the wasp was never upgraded so it could not get a port, only a PID. 
- Reran the UMP install from the primary. 

- maintenance_mode and nas probes were not stable. 

- Started maintenance_mode probe because it was down. 

- Cold started nas and the probes were now in a good state so we could continue with the UMP upgrade. 

- Finished the upgrade and UMP robot/wasp etc., were all in good shape so we accessed the UMP URL and logged in to UMP. 

Checked PRD and alarms and USM and everything was working as expected.