Upgrade SDM 12.9 to 17.1 return ExitCode 231 during migration task at 49%
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Article ID: 132056
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Updated On:
Products
CA Service Management - Asset Portfolio Management
CA Service Management - Service Desk Manager
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Issue/Introduction
Upgrade SDM 12.9 to 17.1 return ExitCode 231 during migration task at 49%
Customer used the procedure below, but the error persists:
ca-sdm-migration-fails-with-exitcode-231-error
Environment
Service Desk Manager 17.1
Cause
The errors in the install.log: Tue Apr 30 16:59:28 2019: >> Running Cmd ("E:\CA\SDM\SDM\bin\orcl_check_db.exe" -c 2>&1 |) Tue Apr 30 16:59:29 2019: >> SEVERE_ERROR: Unable to load OCI library (oci.dll) RC(193) Tue Apr 30 16:59:29 2019: >> SEVERE_ERROR: Unable to load OCI library (C:/oracle/product/11.2.0/client_2/lib/oci.dll) RC(126) Customer has Oracle client 64bit SDM 17.X works fine with oracle 12, but need client 32 bits (also support ora11) . the messages state OCI lib 32 bits not found
Resolution
Install Oracle client 32bit
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