Almost ALL probes Down with restarts reached for probe in the log

book

Article ID: 131993

calendar_today

Updated On:

Products

DX Infrastructure Management NIMSOFT PROBES

Issue/Introduction

All this probes with Red / Down State:


ace

alarm_enrichment

discovery_server

ems

maintenance_mode

mon_config_service

nas

relatioship_services

sla_engine

trellis

udm_manager



User-added image


User-added image

You will see that Some probes will generate just "restarts reached for probe" Messages in the log


Trellis probe will not generate any log


You will find this messages in the Ems and udm_manager logs:



Ems.log:
========

[main, ems] Failed to parse connection string as : Received status (4) on response (for sendRcv) for cmd = 'nametoip' name =

'/UIM_Domain/UIM_Primary_hub/Primary_hub/data_engine'

stderr: org.springframework.beans.factory.UnsatisfiedDependencyException: Error creating bean with name 'emf' defined in class

path resource [com/nimsoft/events/common/config/DataAccessConfig.class]:



Caused by: org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'databaseConnectionInfo'

defined in class path resource [com/nimsoft/events/common/config/DataAccessConfig.class]: Bean instantiation via factory method

failed; nested exception is org.springframework.beans.BeanInstantiationException: Failed to instantiate

[com.nimsoft.nimbus.lookup.model.DatabaseConnectionInfo]: Factory method 'databaseConnectionInfo' threw exception; nested

exception is (1) error, Received status (1) on response (for sendRcv) for cmd = 'get_connection_string'




udm_manager.log:
==================

DEBUG [main, udm_manager] Looking up database connection info. 

FATAL [main, udm_manager] Probe exception: (1) error, Received status (1) on response (for sendRcv) for cmd =

'get_connection_string' 

FATAL [main, udm_manager] (1) error, Received status (1) on response (for sendRcv) for cmd = 'get_connection_string' 







 

Cause

Its not Supported to use newer version of data_engine with older version of the product

Environment

UIM 8.5.1 SP1
Data_engine 9.0.2

Resolution

Deploy data_engine 8.50 probe version over data_engine 9.x version

IF the issue persists, then:

Option 1 - This behavior dealing with missing in incompatible database schema , you will have no choice but to roll back to the last DB Backup or do a clean database install

Option 2 - Upgrade the Entire environment to the same Data_engine Version so 9.x

 

Attachments