Universe connector import failing for duplicate users
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Universe connector import failing for duplicate users

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Article ID: 131961

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Updated On:

Products

CA Identity Manager CA Identity Governance CA Identity Portal

Issue/Introduction

When importing Active Directory Endpoints into CA Identiy Goernance via the CA Identity Manager Connector, the import fails with the error below:

Cannot insert duplicate key in object 'dbo.Users'. The duplicate key value is (610, auser).; nested exception is java.sql.BatchUpdateException: Violation of UNIQUE KEY constraint 'IX_Users'. Cannot insert duplicate key in object 'dbo.Users'. The duplicate key value is (610, auser). 
16:23:28,528 ERROR [stderr] (import-connector thread-9) at com.eurekify.command.AbstractCommand.execute(AbstractCommand.java:54) 

Environment

CA Product = IDENTITY MGMT AND GOVRNCE
Product Release =14.1 CP3
 

Cause

This issue is caused by duplicate database entries.

Resolution

To address this issue, purge the Identity Governance Universe.  Good management practice requires you to purge old, unneeded data files from the CA Identity Governance database server periodically, so this is not detrimental to the overall functionality.

 

Additional Information

Please refer to the CA Identity Management product documentation for further information on purging data.

https://docops.ca.com/ca-identity-governance/14-1/EN/administrating/purge-data

Also see the related Knowledge Base articles.

How to identify duplicates encountered during an Identity Governance import?
How to allow IG Imports to continue with duplicates.