API Gateway: Connection to the Gateway has been broken
search cancel

API Gateway: Connection to the Gateway has been broken

book

Article ID: 131955

calendar_today

Updated On:

Products

CA API Gateway

Issue/Introduction

When logging in to Policy Manager, the below error occurrs:
 

"Connection to the Gateway has been broken."

Environment

API Gateway 11.x

Policy Manager 11.x

Cause

There are some different reasons that could cause the issue: 

1.  Java version mismtach:  The policy manager and gateway are in different version (policy manager is for a different version). 

2.  Gateway ssg log size very large. 

3. Gateway DNS server connection problem or related to DNS service issue. 

Resolution

  1. On your CA API Gateway, the size of the log file ‘ssg_0_0.log’ may become very large which could prevent successful Policy Manager logins.
    • Deleting the file and restarting the CA API Gateway may be a way of remediating this issue if the root cause is a large ssg_0_0.log file.
  2. Also, possible approach:
    • Adding the connection property setting of sendStringParametersAsUnicode = false on the jbdc connection the performance could improved greatly.  If the connection is trying to call with nvarchar vs. varchar and that was forcing a conversion to happen on the db which is why the response times could be slow.
  3. If there is error message in the ssg log:     

    4042: Problem   to https://<hostname>:<port>/. Error msg: Unable to obtain HTTP response from https://<host name>:<port> /: Unknown host: <host name> 
        Then verify the DNS service to see if it works properly in the gateway, resolve the DNS service issue with network engineer (connectivity,  DNS server is working etc.).