Find & Reserve model is unable to connect using Connection Profile

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Article ID: 131889

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Updated On:

Products

CA Test Data Manager (Data Finder / Grid Tools)

Issue/Introduction

When running the Find & Reserve Data Model, the find fails with a 500 error: WCM-SIT-3 - Connection is not available, request timed out after 10000ms. However, testing the Connection Profile from the configuration page works fine. 

Cause

Since there is no way to remove a connection profile from an Environment in Portal, we created a new Project and Environment to test only the necessary Connection Profile (WCM - SIT-3), we were able to create the Find & Reserve model and retrieve data.

The problem is due to the "WEALTH_WOT" connection profile, which is not needed for this particular environment that has been defined in Portal.

Environment

TDM Portal 4.7.0.14
The user account name: wot_tdm_lead
Project name: Wealth_Client_Master [WCM - SIT 3]. 

The Connection Profiles configuration page for Portal shows only 3 Connection Profiles defined for this user/project: 
DB2 SI0T (DBMS DB2) 
WCM - DEV (DBMS Oracle) 
WCM - SIT-3 (DBMS Oracle) 

The WCM-SIT environment has two Data Sources: 
  • WCM-SIT-3 (Connection Profile: WCM - SIT-3) Oracle DB 
  • WCM_ACC (Connection Profile: WEALTH_WOT) SQL SERVER DB 

The TDMFindReserve.log only shows entries for the WEALTH_WOT connection profile, where the TDMConnectionProfileManager.log shows Connection Profile "WCM - SIT-3" is loading the oracle.jdbc.OracleDriver, and the "WEALTH_WOT" profile shows it is using the jdbc.SQLServer, and this is throwing an exception: 
2019-04-29 09:37:42.294 UTC [ERROR] [find-reserve-sync ] --- [U:][M:][P:] c.c.t.f.d.s.SyncTask: Sync task for DataViewInstance{id=1ccfa510-e159-4f2d-9676-fc3884636b02, profileName='WEALTH_WOT', dataView=AbstractDataView{id=bf4cce29-2c40-43f5-a0d4-ad112a18f60e, profileName='WEALTH_WOT', projectId=2570, versionId=2571, sourceTable='SIT_WOT_Final', schema='null'}, createdAt=2018-10-04T20:04:40.333Z, updatedAt=2018-10-04T20:04:40.488Z, dataTableName='dvid_0b761ec7eea444028b97a8423', pendingDelete=false, schema='null'} failed 
com.microsoft.sqlserver.jdbc.SQLServerException: Invalid column name 'CLIENT_NUMBER'.
 


When running the Find& Reserve Data Model, the find fails with a 500 error: WCM-SIT-3 - Connection is not available, request timed out after 10000ms. However, testing the Connection Profile from the configuration page works fine. 

Resolution

Engineering reviewed the case and they determined that the best way to resolve the issue is to delete the Environment from Portal and recreate it. They said it is too risky to try hacking the database to delete the problematic connection profile.