agent service did not respond to the start request in a timely fashion
book
Article ID: 131880
calendar_today
Updated On:
Products
CA Workload Automation AE - Business Agents (AutoSys)CA Workload Automation AE - Scheduler (AutoSys)Workload Automation Agent
Issue/Introduction
Agent Failed to Start
Error:
Agent service is starting... The service did not respond to the start request in a timely fashion
Environment
RHEL 7: 3.10.0-514 RHEL 6: 2.6.32-696
Cause
This is documented in the System Agents documentation Know Issues section. https://techdocs.broadcom.com/us/en/ca-enterprise-software/intelligent-automation/workload-automation-system-agent/11-4/release-notes.html#concept.dita_bd89790266bbc0a2aa13e33f3a0e96944a4bf911_KnownIssues
Resolution
To correct this problem, Red Hat recommends that you update to a newer version of the Linux kernel.
To work around this issue, Red Hat recommends that you increase the Java stack size by setting "-Xss2m" in the Java startup parameters. For the System Agent, that means you must add the following setting to the agentparm.txt file.
oscomponent.jvm.x.options=-Xss2m
For more information from Red Hat about this issue, see the following documents: