Unable to reach CABI JasperReports Server failure during CABI Jasper server configuration
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Unable to reach CABI JasperReports Server failure during CABI Jasper server configuration

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Article ID: 131872

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Updated On:

Products

CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager

Issue/Introduction

When the 17.2 installer is run against CABI 6.4.3 URL, below error message is seen:
Unable to reach the CABI JasperReports Server. Before you try again, verify the configuration details and the server status.

c:\stdout.txt  from the server where the installer spit out the error message shows entries like this:
 
05/02 08:45:09.131 INFO JasperServerValidator.java 119 Jasper server rest URI :HTTP://CABI-Jasper-HostName:8080/jasperserver-pro/rest/login 
05/02 08:45:10.555 INFO JasperServerValidator.java 165 Response Code from Jasper Server Rest Call :302 
05/02 08:45:10.556 INFO JasperServerValidator.java 166 Response Message from Jasper Server Rest Call :null 
05/02 08:45:10.556 ERROR JasperServerValidator.java 182 Unable to contact server ivd-sdm-xfloweb Response code : 302 
05/02 08:45:10.557 DEBUG JasperServerPage.java 710 CABI validation Done. 


JasperServer's localhost log contains an entry like this:
10.10.10.123 - - [02/May/2019:08:45:10 -0700] "POST /jasperserver-pro/rest/login HTTP/1.1" 302 -

Environment

Release:
Component: SMJSPR

Cause

CABI JasperReports Server was already configured to use LDAP authentication. This is somehow interfering with the installer's ability to authenticate using the superuser account.

Resolution

1) Backup the LDAP configuration enabled in CABI JasperReports Server
2) Remove the LDAP configuration settings in CABI JasperReports Server, restart CABI Jasper Tomcat
3) Let the 17.2 installer continue with the integration of Service Management 17.2 with  CABI JasperReports Server now
4) Once the installation/configuration is successful, enable LDAP configuration back again in CABI JasperReports Server.