On upgrade from 12.9 to 17.1 the creation of CDB fails

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Article ID: 131833

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Updated On:

Products

SUPPORT AUTOMATION- SERVER CA Service Desk Manager - Unified Self Service KNOWLEDGE TOOLS CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager

Issue/Introduction

On upgrade from 12.9 to 17.1 the creation of CDB fails.
The install.log shows:
Connection to mdb database failed 
com.microsoft.sqlserver.jdbc.SQLServerException: Invalid object name 'al_cdb_componentinstallstate'. 

Cause

12.9 did not have the al_cdb* tables for SDM installs. 
One of the first steps in the upgrade process creates these tables.
However if this fails it does not log this cause to install.log.
If you check the C:\Users\username\AppData\Local\Temp\casm\mdb\install_mdb.log
you may find the error there such as:

05-06,15:22:44 ERROR - com.microsoft.sqlserver.jdbc.SQLServerException: The transaction log for database 'mdb' is full due to 'LOG_BACKUP'. 
com.microsoft.sqlserver.jdbc.SQLServerException: The transaction log for database 'mdb' is full due to 'LOG_BACKUP'. 
at com.microsoft.sqlserver.jdbc.SQLServerException.makeFromDatabaseError(SQLServerException.java:217) 

Environment

Release:
Component: USRD

Resolution

For the example above, the solution was to increase the transaction log. However if it was a rights issue or something else preventing creation of these tables then this would need to be solved.

Additional Information

note that 17.1 allows upgrades from 12.9 directly to 17.1
However 17.2 says you must go from 12.9 to 14.1 first and then to 17.2.