Jaspersoft "Database Connection Check" report error after move of Clarity DB
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Jaspersoft "Database Connection Check" report error after move of Clarity DB

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Article ID: 131719

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Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

After moving our Clarity production database to a new server (new hostname) and updating the jdbc connection string for the application in the properties.xml file with the new hostname, the out-of-the-box report "Database Connection Check: CA PPM" does not work anymore.

Error: 

The server has encountered an error. Please excuse the inconvenience.
Error Message:
An error occurred while creating the connection. Try again.

Impacted reports include:

  • PPM Schema
  • Portfolio Plan Changes
  • Portfolio Plan Changes – Waterline and Rank
  • Portfolio Plan Comparison
  • Project Change Request Register
  • Project Planning Schedule
  • User Access Rights
  • User Access Rights Detail
  • User License and Activity
  • User License and Activity Detail
  • Database Connection Check: CA PPM
  • Project Earned Value
  • Project Issue Register
  • Project Risk Register

Environment

Release: All Supported Releases
Component: Clarity Jaspersoft

Cause

This issue can happen after changes are made to the Database. The reason why only certain reports are impacted is because reports use two different data sources. Those impacted by this issue are those using the Data Source: PPM Bean Data Source. 

Resolution

Run the following commands:

admin update jasperParameters

admin jaspersoft syncPPMContext -userName superuser -password superuser

Additional Information

See also: Jaspersoft / reports known issues with Clarity