PeopleSoft ERP agent fails to handshake with the policy server
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PeopleSoft ERP agent fails to handshake with the policy server

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Article ID: 131709

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Updated On:

Products

CA Single Sign On Secure Proxy Server (SiteMinder) CA Single Sign On SOA Security Manager (SiteMinder) CA Single Sign-On

Issue/Introduction

After installing the PeopleSoft ERP agent, after restarting PeopleSoft we see that the agent reports it is not connected, and there is a handshake error from the PeopleSoft system's IP in the policy server smps.log

Environment

OS: Unix
Agent version: 12.51 PeopleSoft ERP agent
Policy server version: 12.51 and newer

Cause

In order for the agent to properly communicate with the policy server, the CAPKI libraries need to be located via the CAPKIHOME environment variable.  The agent is able to run somewhat, and will even try to connect to the policy server if CAPKIHOME is missing, however it will continually fail the handshake of the trusted host.

Resolution

The current PeopleSoft agent documentation mentions that you need to source the environment variables from ca_peoplesoft_env.sh before starting the PeopleSoft server, however it does not mention that simply sourcing them to your unix shell is not enough.  To have the CAPKIHOME environment variable available to PeopleSoft, you need to add it manually to the psappsrv.ubx file within the PeopleSoft installation.

Review your <peoplesoft agent installation>/ca_peoplesoft_env.sh file and copy the CAPKIHOME line.  Add this line to the PeopleSoft server's psappsrv.ubx file, anywhere within the file should be fine.  The line should look something like this:

CAPKIHOME=/home/1251peoplesoft/CA/peoplesoft/CAPKI

Once this is in place, restart the PeopleSoft server and your agent should now connect successfully to the policy server.