Some of the alarms and models of services are missing and don't all appear in the SOI console
search cancel

Some of the alarms and models of services are missing and don't all appear in the SOI console

book

Article ID: 131566

calendar_today

Updated On:

Products

CA Service Operations Insight (SOI)

Issue/Introduction

Some of the alarms and models of services are missing and don't all appear in the SOI console. The soiui-debug.log contains the following error message repeated many times:

INFO [ServiceManager] security.ModelPrivilegeSecurity.getSecurityChecker(195) - Error parsing security string: 1000000000e686||100000000031a9|100000000015b2|100000000015b1|10000000008dd8|100000000031a5|10000000009a8d|1000000001aa1d|1000000000426a|10000000007c21|1000000001d330|1000000000a1a0|10000000006bef|100000000066b1|100000000031a1|10000000002f5d|ADMIN|100000000031a0|1000000001d2e7|10000000008b86|1000000001d32f: Invalid literal: null

Environment

SOI 4.0

Cause

The error message found in the soiui-debug.log has an extra pipe symbol returned in the defined securitygroup. These entries wind up in the CI and SecurityGroup table values causing the problem. In the soiui-debug.log example we see:

...1000000000e686||100000000031a9|100000000015b2|....

The double pipe between values should not be there, it should be a single pipe.

Resolution

To resolve the issue you need to do the following:
1) Shut down all the SOI services on the SOI manager and UI server

2) Run the following two SQL queries to remove the double pipe in the SOI database tables:

       A) Update CI SET SecurityGroups = Replace(SecurityGroups, '||', '|') WHERE SecurityGroups like '%||%'
       B) truncate table userSecurityGroup

3) Start all the SOI services on the SOI manager and UI server