SDM: Errors when loading r17_1_update.dat and r17_2_update.dat
book
Article ID: 131395
calendar_today
Updated On:
Products
SUPPORT AUTOMATION- SERVERCA Service Desk Manager - Unified Self ServiceCA Service Desk ManagerCA Service Management - Asset Portfolio ManagementCA Service Management - Service Desk Manager
Issue/Introduction
While running the post install steps per https://docops.ca.com/ca-service-management/17-2/en/installing/post-installation-tasks/ca-service-desk-manager-post-installation-tasks/post-install-tasks-after-installing-ca-sdm-17-2
Both files produce "Errors: Attempt to insert row in update only mode."
The install.log file under C:\Program Files (x86)\CA\SC\logsXXXX (XXXX is a date/time string) also specify
2019/03/26 16.23.10.029 DEBUG [DeployThread: Running Post Installation steps for CA Service Desk Manager Update(s) : 17.1] [SdmDataLoadAction] Command constructed is cmd = C:/PROGRA~2/CA/SERVIC~1\bin\pdm_load -f C:/PROGRA~2/CA/SERVIC~1\data\r17_1_update.dat -u ... 2019/03/26 16.23.11.418 DEBUG [DeployThread: Running Post Installation steps for CA Service Desk Manager Update(s) : 17.1] [CommonProcessUtilities] Attempt to insert row in update only mode.
2019/03/26 16.23.11.418 DEBUG [DeployThread: Running Post Installation steps for CA Service Desk Manager Update(s) : 17.1] [CommonProcessUtilities] Attempt to insert row in update only mode. ... 2019/03/26 16.51.12.429 DEBUG [DeployThread: Running Post Installation steps for CA Service Desk Manager Update(s) : 17.2] [SdmDataLoadAction] Command constructed is cmd = C:/PROGRA~2/CA/SERVIC~1\bin\pdm_load -f C:/PROGRA~2/CA/SERVIC~1\data\r17_2_update.dat -u ... 2019/03/26 16.51.13.934 DEBUG [DeployThread: Running Post Installation steps for CA Service Desk Manager Update(s) : 17.2] [CommonProcessUtilities] Attempt to insert row in update only mode.
2019/03/26 16.51.13.935 DEBUG [DeployThread: Running Post Installation steps for CA Service Desk Manager Update(s) : 17.2] [CommonProcessUtilities] Attempt to insert row in update only mode.
Environment
SDM 17.1/17.2 Migration or Installation
Cause
Both extract files reference table l1admin_general_config and are manipulating IDs 4189 and 4190, which do not exist in the backend database table
Resolution
Record id's 4189 and 4190 were being updated on table l1admin_general_config are no longer of concern as they pertain to the older OpenFire functionality used in xFlow for collaboration, which is no longer being used. The functionality is being handled by native microservices.
In the r17_2_update.dat file, the same table names both of these rows by their ID and has a delete_flag set to "1" which effectively means the entries are to be disregarded. Their absence would have the same effect, though it is understandable to why this could appear to be a concern, when it is a false alarm.