Client Automation - OSIM installation generates duplicate computers

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Article ID: 131389

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Products

CA Automation Suite for Data Centers - Configuration Automation CA Client Automation - Asset Management CA Client Automation - IT Client Manager CA Client Automation CA Client Automation - Remote Control CA Client Automation - Asset Intelligence CA Client Automation - Desktop Migration Manager CA Client Automation - Patch Manager

Issue/Introduction

OSIM installation of computer with multiple Network Interface Cards (NIC) may cause duplicate entry in All Computers folder.

The computer is preregistered manually under All Computers using the MAC Address of first NIC card.
An OSIM job is assigned to it.



 

 



After OSIM installation, a new entry is created under All Computers folder.
The machine appears in duplicate : one for the preregistration and one generated by ITCM Agent installed on the computer.
 

 

Cause

The MAC Address for duplicate computers are not the same. ITCM Agent has reported another NIC card as primary network address during registration process.

ITCM Engine uses following criterias to check if the computer does exist already in database :

1- host_uuid.  
(Preregistered computer has host_uuid set to NULL.)

2- host_name and serial number and mac_address. 
(Preregistered computer has same host_name but mac_address may not equal.)

3- host_name and (mac_address or mac_address is empty or mac_address is NULL)
(Preregistered computer has same host_name but mac_address may not equal and not empty/NULL)


 

Environment

Client Automation 14.0 SP2

 

Resolution

Workaround :
During preregistration of the computer, let the "Mac Address" field empty.
In this case Engine detects that it is same computer using the criteria 3 :

 

host_name and (mac_address or mac_address is empty or mac_address is NULL)




Solution :

Open a case at Technical Support requesting the fix T5IZ401 for Client Automation 14.0 SP2

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