Error exporting data only to Excel from a list with an aggregation row
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Error exporting data only to Excel from a list with an aggregation row

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Article ID: 131320

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Updated On:

Products

Clarity PPM SaaS Clarity PPM On Premise

Issue/Introduction

An error might occur when exporting data only to Excel from a list, when the first field on the list is a Boolean type of field.
It occurs for any list that has an aggregation row configured. 


STEPS TO REPRODUCE 
  1. Login to CA PPM, classic UI
  2. Go to Home - Portfolio - Application Management - Investments  (this list has an aggregation row)
  3. Configure a Boolean field as the first column (use 'Active' or 'Above Waterline')
  4. Click 'Save and Return'
  5. Export to Excel (Data Only) - Save the file and Open
    • Error: The file format and extension of 'Portfolio_Investments_List.xls' doesn't match. The file could be corrupted or unsafe. Unless you trust the source, don't open it. Do you want to open it anyway?
    • Click Yes
    • The file still does not open - an error message appears indicating that the file is corrupted
Expected Results: File should Open
Actual Results: File Does not Open
"Error: The file format and extension of '<name_of_file>.xls' doesn't match. The file could be corrupted or unsafe. Unless you trust the source, don't open it. Do you want to open it anywa

Environment

CA PPM 15.5
CA PPM 15.5.1

Cause

This is being caused by Defect DE45701 
 

Resolution

The Defect DE45701 is fixed in 15.6

As a workaround on 15.5 and 15.5.1: 
Move the Boolean field so that it is not the first column on the list. 
OR 
Remove the aggregation row.