Unable to enter time on incidents if the user does not have "Timesheets - Edit All" access right
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Unable to enter time on incidents if the user does not have "Timesheets - Edit All" access right

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Article ID: 131279

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Updated On:

Products

Clarity PPM SaaS Clarity PPM On Premise

Issue/Introduction

STEPS TO REPRODUCE:
1. Create an user and grant every access right except "Timesheets - Edit All"
2. Ensure the resource is Open for Time Entry and the Track Mode is set to PPM
3. Create a service called MySrv or any other type of investment
4. At Data Administration > Create an Incident Category > My cat
5. On the Associated Investments tab, add the MySrv serviceĀ 
6. Home > Demand Management > Incidents
7. Create an incident called MyInc
8. On the bottom of the page, you see the Enter Time button
9. Click on the button

Expected Result: Timesheet to open and be able to enter time.
Actual result: Error 401 - Unauthorized. You are not authorized to view the page. If you are sure you have access, try logging in again or contact your system administrator.

Environment

Clarity PPM 15.6

Cause

This is caused by DE48768

Resolution

This is fixed within 15.7 and backported to 15.6.1.2


Workaround for:

 

Add the "Timesheets - Edit All" access right

OR

Use the timesheets directly to enter time to incidents.