snmpcollector stops collecting/publishing data
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snmpcollector stops collecting/publishing data

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Article ID: 131257

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM) Unified Infrastructure Management for Mainframe CA Unified Infrastructure Management SaaS (Nimsoft / UIM)

Issue/Introduction

After a restart of the snmpcollector probe, it stopped displaying QOS data in USM Performance Reports Designer (PRD).

Environment

- UIM v9.0.2
- snmpcollector v3.44 or higher

Cause

- snmpcollector probe restart

Resolution

It is expected after a restart of the snmpcollector to not see all the QOS data for some profiles/OIDs/QOS objects, sometimes for many hours, and up to 24 hours. This depends on how many devices are being monitored and the polling frequency/number of metrics being collected per instance of the snmpcollector probe. The snmpcollector probe must first discover all the devices and components and their related configurations to be monitored.

Also, SNMP v2c allows bulk processing but SNMP v1 does not, so v2 is preferable in terms of overall performance. Network factors will play a part as well, e.g., latency between the snmpcollector probe and the monitored devices.

In some cases, it may be advantageous to split up the monitoring over 2 or more instances of the probe depending on how long it takes to complete the discovery after a probe restart.