Portal On-demand report shows Get property operation returned empty data set error
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Portal On-demand report shows Get property operation returned empty data set error

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Article ID: 131233

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Updated On:

Products

CA Performance Management Network Observability Spectrum

Issue/Introduction

On-demand report in CA Performance Management (CAPM) fails with error - "Get property operation returned empty data set"

On NetOps Portal from Reports->New, I get below error and the template run & save options are grayed out.  I also noticed there is no available metrics to select. We only have a Spectrum Data Source integrated with Portal.

When running an on-demand report for any device or group in CAPM, the following error is seen: "Get property operation returned empty data set"

Environment

All supported Network Observability DX NetOps Performance Management and Spectrum releases.

Cause

There are two possible causes for this to appear.

  • The RIB cache on the Portal server in the /tmp/ribcache directory has become corrupted.
  • There is no Data Aggregator Data Source integrated with the Portal web server.

Resolution

To resolve the first issue when a Data Aggregator Data Source is present we need to rebuild the RIB cache on the Portal server. To do so complete the following:

  1. Stop the Portal web server console and device manager services in the following order.
    1. systemctl stop caperfcenter_console
    2. systemctl stop caperfcenter_devicemanager
  2. Change to the /tmp directory using the command "cd /tmp"

  3. Delete the ribcache directory using the command:

    rm -rf /tmp/ribcache

  4. Start the Portal web server console and device manager services in the following order.
    1. systemctl start caperfcenter_devicemanager

      Wait 20 seconds then run...

    2. systemctl start caperfcenter_console

  5. Close and reopen any browser with open Portal tabs. Log into Portal and validate the error is resolved. Note that it may take several minutes for the rib cache to repopulate.

 

To resolve the missing Data Aggregator Data Source, if not installed, please contact Support for additional information. The steps to install a Data Aggregator and related systems are found in the Installing Performance Management documentation topic.

Additional Information

How to properly restart the CAPM environment:  

KB : How to properly restart the DX NetOps environment