A2A Client no working after pointing it to a different PAM server
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A2A Client no working after pointing it to a different PAM server

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Article ID: 131228

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Updated On:

Products

CA Privileged Access Manager - Cloakware Password Authority (PA) CA Privileged Access Manager (PAM)

Issue/Introduction

You need to point your A2A client to a different PAM server, but after doing so the client is not working.

Cause

You missed to remove the A2A client cache file .cspmclient.dat, which contained references to the old PAM server.

Resolution

To reconfigure an A2A client to use a different PAM Server:

  1. Stop the A2A Client.
  2. Go to $CSPM_CLIENT_HOME/cspmclient/config/data and delete file .cspmclient.dat.
  3. Update the <cspmserver> entry in the client configuration file with your new server name. For example:
    <cspmserver>new_server.example.com</cspmserver>

The client configuration file is $CSPM_CLIENT_HOME/cspmclient/config/cspm_client_config.xml.

$CSPM_CLIENT_HOME is your installation directory, for example /opt/cloakware on UNIX/Linux or C:\cspm\cloakware on Windows.

 

To stop the A2A Client:

•   On UNIX enter:
cspmclientd stop
 
•   On Windows, stop the cspmclientd service using the Services Administrative tool:
Find the tool by searching for "Services", or navigate to Start > Control Panel > Administrative Tools > Services, or run services.msc from a CMD window. Select cspmclientd in the Services list, and then click Stop.
–or–
Open a command line window and enter:
net stop cspmclientd
 
To start the A2A Client:
•   On UNIX enter:
cspmclientd start
•   On Windows, start service cspmclientd using the Services Administrative tool:
Find the tool by searching for "Services", or navigate to Start > Control Panel > Administrative Tools > Services, or run services.msc from a CMD window. Select cspmclientd in the Services list and then click Start.
–or–
Open a command line window and enter:
net start cspmclientd