cluster probe failing to connect to ip/host

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Article ID: 131204

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Updated On:

Products

DX Infrastructure Management NIMSOFT PROBES

Issue/Introduction

After deploying the cluster probe, we see it failing to connect to secondary nodes with this error:
 

Apr 22 12:23:41:420 [12592] cluster: (updateGroupConf) - Session Send failed to ip/host=x.x.x.x
Apr 22 12:24:41:675 [14376] cluster: (updateGroupConf) - Session Send failed to ip/host=x.x.x.x 
Apr 22 12:25:41:690 [8860] cluster: (updateGroupConf) - Session Send failed to ip/host=x.x.x.x
 

Cause

In this case, the issue was being caused by a timeout with the network connection between the two nodes.

Environment

UIM version 8.51 
cluster probe version 3.50

**This information is generally applicable to all versions of UIM / Cluster probe

Resolution

Raise the communication_timeout value within the probe configuration to allow the probe additional time to make the connection.


> deactivate the probe
> open the raw configuration for the probe in Infrastructure Manager or Admin Console
> in the <setup> section section, raise the communication_timeout key
> activate the probe
 
 
The recommendation is to raise the value by 20 with each test. Repeat if necessary.
If you continue to see the issue after reaching around a value of a 100, please open a ticket with Support for continued investigation.
It is not recommended to raise the value too high, as this can bog down the network with continuous traffic.

Additional Information

Cluster probe documentation:
https://techdocs.broadcom.com/content/broadcom/techdocs/us/en/ca-enterprise-software/it-operations-management/ca-unified-infrastructure-management-probes/GA/cluster-clustered-environment-monitoring.html