Clarity PPM: JDK 1.8 Needed when Upgrading from 15.3 to 15.6

book

Article ID: 131203

calendar_today

Updated On:

Products

CLARITY PPM FOR ITG CLARITY PPM FEDERAL Clarity PPM SaaS - Application Clarity PPM On Premise

Issue/Introduction

During the Clarity upgrade, the installer asks for JDK 1.8, but the server already has JDK 11 installed as it is required for the 15.6 target release.

At least one release in the release list requires JDK 1.8.
Oracle Java SE JDK 1.8 build 191 (64-bit) or higher patch level is recommended.

Environment

Release:
Component:

Resolution

The upgrade prompts will ask for both the JDK 1.8 directory and the JDK 11 directory so both JDK 1.8 and JDK 11 will need to be installed on the server for the upgrade to be successful.

Additionally, the JAVA_HOME environment variable should be set to point to JDK 11 corresponding to the target Clarity release.