UIM connector stays in initializing then goes to offline
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Article ID: 131186
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Updated On:
Products
CA Service Operations Insight (SOI)
Issue/Introduction
UIM connector stays in initializing state, not coming online and not publishing alert to SOI
Environment
Release: Component: SOIMGR
Cause
The following error in UIMConnector.log suggest there is an issue with the Catalyst queue client created in UIM primary hub. "Unable to empty alarm message queue Catalyst: invalid argument"
Resolution
- In our investigation we found that the Catalyst Queue was missing in UIM primary hub. Note: Typing the name wrong would also result in similar error. To resolve the problem - Create the Catalyst queue as per documented procedure in "https://docops.ca.com/soi-connectors/ca-unified- infrastructure-management-uim-connector- 3-9-0/install-upgrade-uninstall-ca-uim-connector" under section "Configure the Message Queue in CA UIM" - Stop the catalyst container service on the UIM connector machine - Delete all files from CA\Catalyst\CatalystConnector\container\datastore and CA\Catalyst\CatalystConnector\container\nls-store - Start the catalyst container service on the UIM connector machine