Service Point Integration Problem

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Article ID: 131119

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Updated On:

Products

CA Service Catalog CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager

Issue/Introduction

More option icon is not showing up on Service point web interface

searchMS.log has:
================
java.util.concurrent.CompletionException: [Attach Error: PozError, Attach 
Error: PozError, PE_NOTFOUND Object Not Found, PozFactory.attach: unable to 
attach, PozFactory.attachPoz: error invoking iPoz::ClientAttach on host 
itasm, CERT-CA Service Catalog, Service Catalog] 
com.ca.eiam.SafeException: EE_NOTFOUND Object Not Found 

Cause

Catalog application instance is not registered to correct application instance name i.e. "CA Service Catalog" instead of "Service Catalog"

Environment

CA Service Management 17.2
xFlow / Service Point / USS / Search Server
Embedded Entitlements Manager (EEM) 12.6

Resolution

To solve the issue, verify below details: 

1. EEM -> Service Catalog application -> 
2. Manage Access Policies -> Policies -> Explicit Grants ->
uncheck Show Policies matching name check ON show policies matching identity type: <username> in Add Identity and click Plus icon -> click Go 
3. Select the Explicit Denies tab and scroll to the bottom to find: 
GroupSearchScopingPolicy 
4. Click on it, 
5. Delete user dbell in the Selected Identities section 
6. Uncheck Explicit Deny 
7. Click Save. 

Note: xFlow restart is not needed normally. logout of service point, login again as <username> and retest, it should work OK now and expose the offerings in SP.

If above steps do not work
------------------------------------
1. Ensure you have correct instance registered to EEM
Note: Ideally SM 17.2 CAT application will register the application name as "Service Catalog" , if not the case then continue with next step
2. Run the Service Configuration to update the name with correct application name
3. Update the application name from "CA Service Catalog" to "Service Catalog" 
4. Recycle the application services i.e. SM relate products i.e.(CA Service Catalog. CA Service Desk Manager, CA xFlow, etc) 
5. Log back to Service Point web application - App Launcher - Select Service Point 
6. Web interface will now present with the more icon option.

Additional Information

To avoid above scenario on new installations - 

After installation of Service Catalog completes - Run the catalog configuration with EEM application registration to have "Service Catalog" instead of "CA Service Catalog".