Symdump batch r 11 is not writing dumps to the Symdump batch repository file. Dump capture fails with message CAPC077E.
book
Article ID: 131113
calendar_today
Updated On:
Products
SymDump for CICSSymDump Batch
Issue/Introduction
The client just installed Symdump batch r 11 and started it on the LPAR using CAIRIM. When symdump batch captured and abending program the dump was not written to the Symdump batch VSAM repository dump file. Instead the abending job output had the following messages.
J0032139 IKJ56228I DATA SET CAI.PRTLIB NOT IN CATALOG OR CATALOG CAN NOT BE ACCESSED J0032139 + CAPC077E ERROR ADDING FILE TO THE CAIPRINT REPOSITORY. J0032139 + CAPC077E Unable to allocate repository
Environment
Z/OS
Cause
The CAOETABL options module parameter PRTLIB= points to Symdump batch repository file that the dumps should be written to. In this case the client was pointing to the default repository name CAI.PRTLIB which does not exist on the clients LPAR.
Resolution
Update the Symdump batch options module CAOETABL parameter PRTLIB= located in PDS HLQ.CAVHJCL(CAOETABL) to point to the correct dump repository name. The default name is PRTLIB=CAI.PRTLIB. Assemble and relink the CAOETABL with the correct dump repository name..
Then do the following steps to implement the changes. 1) If you reassembled default options table into a different library than HLQ.CAVHAUTH(default) then make sure the relinked load library is placed ahead of CAVHAUTH library in the Link List.
2) Refresh LLA and Link List.
3) Refresh the CA SymDump Batch runtime by running CAS9 CAIRIM with a RIMPARM(CAVHTERM) to deactivate runtime. PRODUCT(CA SYMDUMP/INTERTEST) VERSION(VHB0) INIT(CAVHTERM) And then rerun CAIRIM with RIMPARM(CAVHINIT) to activate runtime.
4) After successfully activating the CA SymDump Batch runtime run the options report to verify your pointing to the correct repository dump file. The options report JCL is located in PDS CAVHPROC(CAIOPTNS).