Empty records are seen on the Service Point Configuration Default Areas page and existing records cannot be deleted
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Article ID: 131045
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Updated On:
Products
CA Service Management - Asset Portfolio ManagementCA Service Management - Service Desk Manager
Issue/Introduction
5 empty records are being seen on SDM Administration -> xFlow-Interface -> ServicePoint -> Default Areas page. Existing entries cannot be deleted either.
Cause
1) As part of 17.2 install, the table: default_cat_mapping in SDM has 5 default SDM Category records.
2) Installation/Upgrade does not validate if those SDM Category records being really present on the given SDM installation
Example: SDM offers a Out of the Box category called Email, and this category was deleted on a customer system. 17.2 installation did not check for this scenario, and just adds a reference to this missing SDM category in the default_cat_mapping table.
3) Such orphaned/dangling record is what is causing those empty records to show up on the Service Point Default Areas page.
Environment
Release: Component: SVCMGT
Resolution
1) To resolve this, run below SDM command via a command prompt:
#below command takes a backup of the table first pdm_extract default_cat_mapping > default_cat_mapping.txt
#below command deletes the content of the same table pdm_load -r -f default_cat_mapping.txt
#refresh the cached table with in SDM layers pdm_cache_refresh -t default_cat_mapping
2) Refresh the SDM Service Point configuration page
3) Make sure there are no System locks on SDM Administration -> System -> System Locks page against table default_cat_mapping. If there are any, right click and delete them
4) Add the correct SDM categories now via SDM Administration -> xFlow-Interface -> ServicePoint -> Default Areas