RESTMAN unable to change users password

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Article ID: 131013

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Updated On:

Products

STARTER PACK-7 CA Rapid App Security CA API Gateway

Issue/Introduction

How do I change a users password using restman api ?

Cause

For password change, call of the Restman api, needs the "body" to be the actual raw text of the password (or the hash) - it is in raw bytes/character NOT in xml format as would have expected from the other parts of the API. 
 

Environment

API Gateway 9.3

Resolution


RESTman example : 

https://odoma04-gw.example.com:8443/restman/1.0/users/20b28e068d1cae807d2fd5aef7360a95/password?format=plain 

The "body" is raw password - so all the POST data is taken as the "password" : in my case : 

fred02 

As per the screenshot: 

<Please see attached file for image>

User-added image

 

Attachments

1558687404279000131013_sktwi1f5rjvs16f9g.png get_app