Virtual services are timing out and not responding the requests unless the VSE service is restarted.
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Virtual services are timing out and not responding the requests unless the VSE service is restarted.

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Article ID: 130997

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Updated On:

Products

CA Application Test CA Continuous Application Insight (PathFinder)

Issue/Introduction

Virtual services are timing out and not being able to respond the requests unless the VSE service is restarted.

Environment

All supported DevTest releases.

Cause

The problem happens during an automated test that generates a high number of transactions on a Functional VSE where the capacity for the services are set to 1. 

Resolution

Verify what is the load being generate for the virtual service, Functional VSEs supports 10 TPS which means 1 transaction per 100ms.

If VSE sees more than 1 transaction in 100ms then you will see the message "WARN com.itko.lisa.coordinator.VSETransactionLicensingManager - Transaction processing speed is being gated due to licensing restrictions." in the logs.

If it exceeds 10 transactions per second, we will need to have a performance license for the VSE service.  Your account team can be contacted regarding license questions.