Virtual services are timing out and not responding the requests unless the VSE service is restarted.
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Virtual services are timing out and not responding the requests unless the VSE service is restarted.

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Article ID: 130997

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Updated On:

Products

CA Application Test CA Continuous Application Insight (PathFinder)

Issue/Introduction

Virtual services are timing out and not being able to respond the requests unless the VSE service is restarted.

Environment

All supported DevTest releases.

Cause

The problem happens during an automated test that generates a high number of transactions.
The capacity for the services are set to 1. 

When looking at the vse.log file we found several messages regarding licensing restrictions, what indicates this VSE service is not set for performance. It is restricted to 10 transactions per second. What can be the cause of a queuing issue in the request side.

Transaction processing speed is being gated due to licensing restrictions. 
WARN com.itko.lisa.coordinator.VSETransactionLicensingManager - Transaction processing speed is being gated due to licensing restrictions.
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Resolution

Verify what is the load being generate for the virtual service model. If it exceeds 10 transactions per second, we will need to have a performance license for the VSE service.
The account team can be contacted regarding license questions.