Clarity Custom Processes are failing with error Status-Code: 502: Proxy Error
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Clarity Custom Processes are failing with error Status-Code: 502: Proxy Error

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Article ID: 130907

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Updated On:

Products

Clarity PPM SaaS Clarity PPM On Premise

Issue/Introduction

Clarity PPM custom processes are failing with a 502 Proxy Error
Error in logs:
ERROR: null:1111:55: <soap:invoke> Failed to send a SOAP message generated to 'https://<PPMserver>/niku/xog'.HTTP Error: Status-Code: 502: Proxy Error

Cause

This issue can happen if the processes are XOGing in a large # of records at one time. 

Resolution

Solution 1: Restart app and bg services.

Solution 2: If the above doesn't help or for avoidance of this issue see the following: How many XOG instances should you read/write in a single request?