Problems Checking Out Files After Upgrade
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Problems Checking Out Files After Upgrade

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Article ID: 130883

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Updated On:

Products

CA Harvest Software Change Manager - OpenMake Meister

Issue/Introduction

After upgrading Harvest, we are seeing random errors and problems when performing checkout operations.  Example errors include:

E02020053 Cannot open signature record for <filename>
E03020566 Cannot write signature record for <filename>
E03020175 Server cannot communicate with the agent on machine <servername>

We also find that when checking out in "synchronize" mode, at times, Harvest will check out all files in the folder, even if there were only one or two files in the package being checked out.

What causes this and how can we resolve the problem?

Environment

CA Harvest SCM all versions

Cause

These types of problems can happen

  • If a signature file has become corrupted, 
  • If the format of the signature file for the new version of Harvest has changed

Resolution

The difficulty is that no utility or tool exists that can "repair" or "refresh" a signature file.  In such cases, the best solution is to delete the "harvest.sig" file causing the problem and do a fresh checkout.  In this process, Harvest will create a new signature file.

Additional Information

You can read more about the signature files in the documentation here: Use Check-In and Check-Out in CA Harvest SCM - Signature files

Information about the error messages listed above can be found here:

E02020053 Cannot open signature record for <filename>
E03020566 Cannot write signature record for <filename>
E03020175 Server cannot communicate with the agent on machine <servername>