Resource Planning portlets are not displaying Incident Hours if the Resource is not a team member

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Article ID: 130736

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Updated On:

Products

CLARITY PPM FOR ITG CLARITY PPM FEDERAL Clarity PPM On Premise

Issue/Introduction

If a resource submitting time on an Incident is not on the related applications team when actual hours are posted, the incident actuals do not show up in Resource Planning portlets. If you then later add the resource to the application, any hours posted for the incident going forward are displayed, but not those posted prior to the user being on the team. Additionally, only actual hours posted after the resource is added to the application team are counted on the Application. Actual hours are included at the incident level if you look at the Incident. Portlets impacted include Resource Planning Allocations and Workload.

Steps to Reproduce: 

1. In Clarity PPM, create an application 
2. Click on the application, and from the Properties drop down select ‘Incidents’ 
3. Click ‘New’, enter required fields and click Save and Return to create the Incident 
4. Important: Ensure the user time will be submitted for (User1 in this example) is not on the application team 
5. Ensure the user the time will be posted for (User1) has access to add incidents to timesheets (Incidents - Create/Edit – All) 
6. Navigate to the resource’s current timesheet in Classic UI 
7. Click the Add Incident button 
8. Add the Incident created in step 3 
9. Populate hours for the incident on the timesheet and submit for approval 
10. Approve the timesheet, wait 5 minutes, then run the Post Timesheets job 
11. Navigate to the Resource Workloads portlet 
12. Configure the Time Scaled Value TSV to display Incident Actuals: 
  • Click the Options icon->Configure->List Column Section->Fields 
  • Click the Properties icon next to the Time Scaled Value field 
  • Set Display Type to Number if not set already 
  • Add Incidents to the Selected column under Value Attributes 
  • Set Rolling Date to Start of current week (Or week time was posted above) 
  • Click Save and Return, then Save and Return again 
13. View the Incident Actuals TSV value for User1 for the week actuals were posted 

Expected Results: Incident Actuals display 

Actual Results: The Incident Actuals don’t display. Note: If you add the resource to the application, the previously posted actuals won’t display, but new actuals posted for the incidents associated with the application will display going forward. 

Cause

This issue is caused by DE48284

Environment

Release: CODFSS99000-15.5-PPM SAAS FedRAMP-Sandbox-Small Environment

Resolution

This issue is tentatively planned to be fixed in Clarity PPM 15.7.

Additional Information

See KB000122537  regarding Timesheet hours for Incidents not showing in Capacity Overview Portlet