CA Datacom CAS9 CAIRIM S806 DBRIMPR not found
search cancel

CA Datacom CAS9 CAIRIM S806 DBRIMPR not found

book

Article ID: 130708

calendar_today

Updated On:

Products

Datacom DATACOM - AD CIS COMMON SERVICES FOR Z/OS 90S SERVICES DATABASE MANAGEMENT SOLUTIONS FOR DB2 FOR Z/OS COMMON PRODUCT SERVICES COMPONENT Common Services CA ECOMETER SERVER COMPONENT FOC Easytrieve Report Generator for Common Services INFOCAI MAINTENANCE IPC UNICENTER JCLCHECK COMMON COMPONENT Mainframe VM Product Manager CHORUS SOFTWARE MANAGER CA ON DEMAND PORTAL CA Service Desk Manager - Unified Self Service PAM CLIENT FOR LINUX ON MAINFRAME MAINFRAME CONNECTOR FOR LINUX ON MAINFRAME GRAPHICAL MANAGEMENT INTERFACE WEB ADMINISTRATOR FOR TOP SECRET Xpertware

Issue/Introduction

After upgrading to CA Datacom 14.0, 15.0 or 15.1 from version 12.0 or earlier the CAS9 procedure at IPL (program CAIRIM) fails with a S806 abend code and message:

CSV003I REQUESTED MODULE DBRIMPR NOT FOUND



 

Environment

Release: DATABB00200-14.0-Datacom/AD
Component:

Cause

DBRIMPR no longer exists, it was used to install the Datacom SVC in CA Datacom releases prior to 14.0. Since 14.0 and with 15.0 a nd 15.1, Datacom no longer requires an SVC or a subsystem. It uses the PC Call architecture instead.

Resolution

  • Remove the INIT for DBRIMPR from the CAS9 procedure input.

  • Add the INIT to install the PC call routines using module DBCR5PR. See INSTJCL member AXRIM01(for AD) or BDRIM01 (for DB)  for the CAS9 parameters needed.