Update catalog from 17.1.0.2 to 17.2 - Service Catalog Service will not start
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Update catalog from 17.1.0.2 to 17.2 - Service Catalog Service will not start

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Article ID: 130681

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Updated On:

Products

CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager

Issue/Introduction

After having catalog 17.1.0.2 updated to 17.2 ,  catalog is no longer able to be started successfully ,  in ServiceCatalog.log ,  it throws the following error :

ERROR  | wrapper  | 2019/03/26 15:28:32 | The value of property 'wrapper.java.additional.20', '--add-opens java.base/jdk.internal.ref=ALL-UNNAMED' contains unquoted spaces and will most likely result in an invalid java command line.

Environment

ITSM Service Catalog 17.2 

Cause

From viewService.conf file ,  we saw  that    catalog was pointing to  use  JRE 8 . 

Starting from 17.2 ,   it only supports  Java  11.0.1 or 11.0.2  version    .  Java 8 is on longer supported  .

Please check the supported Java Version in the following documentation :

https://docops.ca.com/ca-service-management/17-2/en/ca-service-management-17-2-release-notes/supportability-matrix#SupportabilityMatrix-Third-PartyCommonComponents

( Note :  you need to click "Third-Party Common Components" link there to expand the content to check its supported Java version ) .

Resolution

1.  OOTB ,    Java 11.0.1 is shipped with  17.2 catalog  .

2.  double click usm.cmd  under USM_HOME folder ( catalog installation home folder )  to open catalog's DOS command line 

3.  run the following ant command to have catalog 17.2 point to OOTB Java 11.0.1  , which is under USM_HOME\embedded\jdk
         ant upgrade-jre

4.  restart catalog service    ( sometimes,  you may need to reboot the server )  


It will resolve this problem .