AWI: Fails to start with 'HTTP ERROR 403' or 'Failed to load the bootstrap javascript: ./VAADIN/vaadinBootstrap.js?=7.7.9'

book

Article ID: 130647

calendar_today

Updated On:

Products

CA Automic Workload Automation - Automation Engine

Issue/Introduction

In a new installation of the Automic Web Interface, or after the upgrade of tomcat, the AWI will not start displaying messages similar to:

If the AWI is accessed without a slash i.e. localhost/awi
You don't have authorization to view this page.
HTTP ERROR 403
or 

If the AWI is accessed with a slash i.e. locoalhost/awi/
Failed to load the bootstrap javascript: ./VAADIN/vaadinBootstrap.js?=7.7.9

The catalina log will also show errors similar to:

org.osgi.framework.BundleException: Unresolved constraint in bundle com.uc4.ecc-ae-sheet-jobs-ps [90]: Unable to resolve 90.0: missing requirement [90.0] osgi.wiring.package; (&(osgi.wiring.package=com.uc4.api)(version>=12.0.0)(!(version>=13.0.0))) [caused by: Unable to resolve 1.0: missing requirement [1.0] osgi.wiring.package; (osgi.wiring.package=javax.security.auth.login)]

Cause

Incompatibility with Tomcat 8.5.39

Environment

Release:
Component: AAUTWI

Resolution

There is a known incompatibility with Tomcat 8.5.39. Upgrade to the latest tomcat 8.5 or 9 available if supported on your version of the Automic Web Interface