RDP Access Method pops up a window about shortcut and unable to logon
search cancel

RDP Access Method pops up a window about shortcut and unable to logon

book

Article ID: 130406

calendar_today

Updated On:

Products

CA Privileged Access Manager - Cloakware Password Authority (PA) CA Privileged Access Manager (PAM)

Issue/Introduction

PAM Users are trying to use RDP Access Method to access target Windows Server.

But they are getting the following popup error and unable to logon.

Popup error

If "Cancel" is pressed, users are not able to logon.


Reproduction Steps:

Step1: Create Stale Shortcuts

At the Windows Workstation Desktop connecting to PAM server, create a shortcut of a file then delete the actual file making the shortcut stale.








Create Shortcut3

Step2: Launch PAM using Internet Explorer and use RDP Access Method to logon.


Launch IE and access RDP

Step3. Popup Alert appears


Popup error

Depending on the shortcut, you may get different popup message and sometimes you do not get the shortcut target filename.

In the above use case, if you "Restore" or "Delete it", you can continue to logon.

If you click "Cancel" you will not logon.


In the following case where the shortcut is for an unavailable network connection or non-existent drive, you do not get to logon at all.


Popup error2

 

Environment

Release:
Component: CAPAMX

Cause

This behavior only happens from a Browser (such as IE).
It is an issue with JAVA and this behavior issue was reported before.
You can refer to an external article here.
https://bugs.openjdk.java.net/browse/JDK-8214924
 

Resolution

There are 2 ways to overcome this.

Option1: Use PAM Client
PAM Client is bundled with extensively tested java runtime version so it is less likely to encounter this issue.
For example, current 3.x.x version of PAM Client uses JRE 1.8.0_181
Please contact Broadcom support if PAM Client also demonstrates this behavior.

Option2: Change the Java Runtime version on your desktop
Uninstall the current JRE and install JRE 1.8.0_181 (to match whichever version of JRE used by PAM Client)
You may want to contact your Java Vendor to report this issue if this is happening on the most recent version of JRE.

This has been tested on JRE 1.8.0_181 on IE and there is no popup alert for shortcuts.
 

Additional Information

3rd party Known Issue: https://bugs.openjdk.java.net/browse/JDK-8214924

Attachments

1558687987471000130406_sktwi1f5rjvs16fge.png get_app
1558687985600000130406_sktwi1f5rjvs16fgd.png get_app
1558687983718000130406_sktwi1f5rjvs16fgc.png get_app
1558687981844000130406_sktwi1f5rjvs16fgb.png get_app
1558687979893000130406_sktwi1f5rjvs16fga.png get_app
1558687978169000130406_sktwi1f5rjvs16fg9.png get_app
1558687976484000130406_sktwi1f5rjvs16fg8.png get_app
1558687973407000130406_sktwi1f5rjvs16fg7.png get_app