Rally - Excel: Error connecting to CA Agile Central
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Rally - Excel: Error connecting to CA Agile Central

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Article ID: 130370

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Updated On:

Products

CA Agile Central SaaS (Rally)

Issue/Introduction

When logging into the Excel plugin using SSO, the following error is shown:
Error connecting to CA Agile Central:
The SSO handshake was successful, but the 'RelayState' was not correctly set.  Contact your administrator to obtain the correct URL parameter to set the SSO handshake 'RelayState' to: https://rally1.rallydev.com/slm/j_sso_security_check?noRedirect=true

Cause

This can occur if a new SSO URL has been configured in our system and the old URL has been deactivated without updating the URL in the Excel add-ins.

Resolution

Update the Excel add-in SSO URL to the new URL.

The new URL would be created with the following:  

This would be the beginning of the URL:
https://sso.rallydev.com/sp/startSSO.ping?

Followed by your partnerIDPid information specific for your company (example below).  This information can be obtained from your internal SSO team:
PartnerIdpId=https://pingidp.f4tech.com&TargetResource=https://rally1.rallydev.com/slm/j_sso_security_check?noRedirect=true

The full URL that would be entered as the SSO URL for Excel would be:

https://sso.rallydev.com/sp/startSSO.ping?PartnerIdpId=https://pingidp.f4tech.com&TargetResource=https://rally1.rallydev.com/slm/j_sso_security_check?noRedirect=true