Reporting Alarm table is not synchronized when one landscape is down

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Article ID: 130358

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Updated On:

Products

CA Spectrum

Issue/Introduction

SRM (Spectrum Report Manager) stops synchronizing the alarm table when a landscape is down or an Archive Manager is unresponsive

Cause

There will be a separate process/thread for each landscape. All these threads are synchronized and handled with a common job queue. 
While processing records/alarms, if there is any error/issue occurred that attenuates the current handler job then it will halt the current process and also notifies the other jobs to stop processing records until it resolves the error/issue. 

This is the existing behavior and it has been there for a long time. There are no architectural changes to this processing. This Handler job is common for other bucket handler jobs also (i.e NCM, SPM... etc). 

Yes, If a landscape is down then it will wait until that landscape is up and reachable then it will start processing the rest of the buckets. 

Environment

CA Spectrum 10.4.0 and below

Resolution

This has been enhanced in DX NetOps Spectrum 10.4.1 release:

https://techdocs.broadcom.com/us/en/ca-enterprise-software/it-operations-management/spectrum/10-4-1/release-information/features-and-enhancements.html#concept.dita_74630ff8e83cd59592f994d76127c7a97e847997_SetReportManagerPreferences

  • Enhanced SRM Alarm Handler
    SRM now processes the synchronization of other landscapes even if one landscape is in the error state.